GHSA-xg75-3277-gvvj

ghsaUSosv

Directory Traversal in serve

view advisory published 2019-03-25Licence: CC-BY-4.0

Versions of `serve` before 7.1.3 are vulnerable to Directory Traversal. File paths are not sanitized leading to unauthorized access of system files. ## Recommendation Upgrade to version 7.1.3 or later

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2019-5417UShigh7.5—
A path traversal vulnerability in serve npm package version 7.0.1 allows the attackers to read content of arbitrary files on the remote server.
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan