GHSA-pmqp-h87c-mr78

ghsaUSosv

XML Entity Expansion and Improper Input Validation in Kubernetes API server

view advisory published 2021-05-18Licence: CC-BY-4.0

Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility. ### Specific Go Packages Affected k8s.io/kubernetes/pkg/apiserver

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2019-11253UShigh7.5—
Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan