GHSA-pg97-ww7h-5mjr

ghsaUSosv

XSS in dojox due to insufficient escape in dojox.xmpp.util.xmlEncode

view advisory published 2020-02-13Licence: CC-BY-4.0

### Impact _What kind of vulnerability is it? Who is impacted?_ Potential XSS vulnerability for users of `dojox/xmpp` and `dojox/dtl`. ### Patches _Has the problem been patched? What versions should users upgrade to?_ Yes, patches are available for the 1.11 through 1.16 versions. Users should upgrade to one of these versions of Dojo: * 1.16.1 * 1.15.2 * 1.14.5 * 1.13.6 * 1.12.7 * 1.11.9 Users of Dojo 1.10.x and earlier should review this change and determine if it impacts them, and backport the change as appropriate. ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ The change applied in https://github.com/dojo/dojox/pull/315 could get added separately as a patch. ### For more information If you have any questions or comments about this advisory: * Open an issue in [dojo/dojox](https://github.com/dojo/dojox/)

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2019-10785USmedium6.1—
dojox is vulnerable to Cross-site Scripting in all versions before version 1.16.1, 1.15.2, 1.14.5, 1.13.6, 1.12.7 and 1.11.9. This is due to dojox.xmpp.util.xmlEncode only encoding…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan