GHSA-j9xp-92vc-559j

ghsaUSosv

SQL Injection in sequelize

view advisory published 2019-11-06Licence: CC-BY-4.0

Affected versions of `sequelize` are vulnerable to SQL Injection. The package fails to sanitize JSON path keys in the MariaDB and MySQL dialects, which may allow attackers to inject SQL statements and execute arbitrary SQL queries. ## Recommendation If you are using `sequelize` 5.x, upgrade to version 5.8.11 or later. If you are using `sequelize` 4.x, upgrade to version 4.44.3 or later. If you are using `sequelize` 3.x, upgrade to version 3.35.1 or later.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2019-10748UScritical9.8—
Sequelize all versions prior to 3.35.1, 4.44.3, and 5.8.11 are vulnerable to SQL Injection due to JSON path keys not being properly escaped for the MySQL/MariaDB dialects.
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan