Denial of Service in protobufjs
Versions of `protobufjs` before 5.0.3 and 6.8.6 are vulnerable to a regular expression denial of service when parsing crafted invalid *.proto files. ## Recommendation Update to version 5.0.3, 6.8.6 or later.
01
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2018-3738US | medium5.5 | — | ||
protobufjs is vulnerable to ReDoS when parsing crafted invalid .proto files. | ||||
02
references
External citations — patches, advisories, analysis.
scry
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan