GHSA-47w3-66wq-cpxg

ghsaUSosv

Improper Input Validation in Apache Kafka

view advisory published 2022-05-24Licence: CC-BY-4.0

In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2018-17196UShigh8.8—
In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated cli…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan