GHSA-49rv-g7w5-m8xx

ghsaUSosv

Cross-Site Scripting in @novnc/novnc

view advisory published 2020-08-28Licence: CC-BY-4.0

Versions of `@novnc/novnc` prior to 0.6.2 are vulnerable to Cross-Site Scripting (XSS). The package fails to validate input from the remote VNC server such as the VNC server name. This allows an attacker in control of the remote server to execute arbitrary JavaScript in the noVNC web page. It affects any users of `include/ui.js` and users of `vnc_auto.html` and `vnc.html`. ## Recommendation Upgrade to version 0.6.2 or later.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2017-18635USmedium6.1Exploit
An XSS vulnerability was discovered in noVNC before 0.6.2 in which the remote VNC server could inject arbitrary HTML into the noVNC web page via the messages propagated to the stat…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan