GHSA-v6rp-3r3v-hf4p

ghsaUSosv

Ruby OpenSSL DoS Vulnerability

view advisory published 2022-05-14Licence: CC-BY-4.0

The decode method in the `OpenSSL::ASN1` module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string. The `openssl` gem that contains this module is patched in version 2.0.0.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2017-14033UShigh7.5—
The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) vi…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan