Cross-site scripting in PHPMailer
PHPMailer versions prior to 5.2.24 (released July 26th 2017) have an XSS vulnerability in one of the code examples, CVE-2017-11503. The code_generator.phps example did not filter user input prior to output. This file is distributed with a `.phps` extension, so it it not normally executable unless it is explicitly renamed, and the file is not included when PHPMailer is loaded through composer, so it is safe by default. There was also an undisclosed potential XSS vulnerability in the default exception handler (unused by default). Patches for both issues kindly provided by Patrick Monnerat of the Fedora Project. ### Impact PHPMailer 5.2.23 has XSS in the "From Email Address" and "To Email Address" fields of code_generator.php. ### Patches Fixed in 5.2.24 ### Workarounds None. ### References https://nvd.nist.gov/vuln/detail/CVE-2017-11503 ### For more information If you have any questions or comments about this advisory: * Open a private issue in [the PHPMailer project](https://github.com/PHPMailer/PHPMailer)
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2017-11503US | medium6.1 | Exploit | ||
PHPMailer 5.2.23 has XSS in the "From Email Address" and "To Email Address" fields of code_generator.php. | ||||
references
External citations — patches, advisories, analysis.
- http://www.securityfocus.com/bid/99293WEB
- http://www.securitytracker.com/id/1039026WEB
- https://cxsecurity.com/issue/WLB-2017060181WEB
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpmailer/phpmailer/CVE-2017-11503.yamlWEB
- https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.24WEB
- https://github.com/PHPMailer/PHPMailer/security/advisories/GHSA-58mj-pw57-4vm2WEB
- https://nvd.nist.gov/vuln/detail/CVE-2017-11503ADVISORY
- https://packetstormsecurity.com/files/143138/phpmailer-xss.txtWEB
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan