GHSA-8jjf-w7j6-323c

ghsaUSosv

Samlify vulnerable to Authentication Bypass by allowing tokens to be reused with different usernames

view advisory published 2018-01-04Licence: CC-BY-4.0

Versions of `samlify` prior to 2.4.0-rc5 are vulnerable to Authentication Bypass. The package fails to prevent XML Signature Wrapping, allowing tokens to be reused with different usernames. A remote attacker can modify SAML content for a SAML service provider without invalidating the cryptographic signature, which may allow attackers to bypass primary authentication for the affected SAML service provider. ## Recommendation Upgrade to version 2.4.0-rc5 or later

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2017-1000452UShigh7.5—
An XML Signature Wrapping vulnerability exists in Samlify 2.2.0 and earlier, and in predecessor Express-saml2 which could allow attackers to impersonate arbitrary users.
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan