GHSA-5726-g6r9-5f22

ghsaUSosv

Potential for Script Injection in syntax-error

view advisory published 2017-10-24Licence: CC-BY-4.0

Versions of `syntax-error` prior to 1.1.1 are affected by a cross-site scripting vulnerability which may allow a malicious file to execute code when browserified. ## Recommendation Update to version 1.1.1 or later.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2014-7192UShigh10.0Exploit
Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remot…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan