GHSA-363h-vj6q-3cmj

ghsaUSosv

Rosetta-Flash JSONP Vulnerability in hapi

view advisory published 2020-08-31Licence: CC-BY-4.0

This description taken from the pull request provided by Patrick Kettner. Versions 6.1.0 and earlier of hapi are vulnerable to a rosetta-flash attack, which can be used by attackers to send data across domains and break the browser same-origin-policy. ## Recommendation - Update hapi to version 6.1.1 or later. Alternatively, a solution previously implemented by Google, Facebook, and Github is to prepend callbacks with an empty inline comment. This will cause the flash parser to break on invalid inputs and prevent the issue, and how the issue has been resolved internally in hapi.

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2014-4671USmedium4.3Exploit
Adobe Flash Player before 13.0.0.231 and 14.x before 14.0.0.145 on Windows and OS X and before 11.2.202.394 on Linux, Adobe AIR before 14.0.0.137 on Android, Adobe AIR SDK before 1…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan