GHSA-f9cm-p3w6-xvr3

ghsaUSosv

Denial-of-Service Extended Event Loop Blocking in qs

view advisory published 2018-10-09Licence: CC-BY-4.0

Versions prior to 1.0.0 of `qs` are affected by a denial of service vulnerability that results from excessive recursion in parsing a deeply nested JSON string. ## Recommendation Update to version 1.0.0 or later

01

describes (1)

Related CVEs.

IDseverity exploitable
CVE-2014-10064UShigh7.5—
The qs module before 1.0.0 does not have an option or default for specifying object depth and when parsing a string representing a deeply nested object will block the event loop fo…
02

references

External citations — patches, advisories, analysis.

scry

Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.

Free scan