Rockwell Automation Logix Controllers
Successful exploitation of this vulnerability could allow an attacker to cause a denial-of-service on the affected products.
describes (1)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2024-8626US | high7.5 | — | ||
Due to a memory leak, a denial-of-service vulnerability exists in the Rockwell Automation affected products. A malicious actor could exploit this vulnerability by performing multip… | ||||
references
External citations — patches, advisories, analysis.
- ICS Advisory ICSA-24-284-18 JSONself
- Recommended Practicesexternal
- ICSA Advisory ICSA-24-284-18 - Web Versionself
- Recommended Practicesexternal
- Recommended Practicesexternal
- Recommended Practicesexternal
- Recommended Practicesexternal
- Recommended Practicesexternal
remediations (12)
- Mitigation1756-EN4TR
Customers using the affected software, who are not able to upgrade to one of the corrected versions, are encouraged to apply security best practices, where possible.
- MitigationCompact GuardLogix 5380
Customers using the affected software, who are not able to upgrade to one of the corrected versions, are encouraged to apply security best practices, where possible.
- MitigationCompactLogix 5380
Customers using the affected software, who are not able to upgrade to one of the corrected versions, are encouraged to apply security best practices, where possible.
- MitigationCompactLogix 5480
Customers using the affected software, who are not able to upgrade to one of the corrected versions, are encouraged to apply security best practices, where possible.
- MitigationControlLogix 5580
Customers using the affected software, who are not able to upgrade to one of the corrected versions, are encouraged to apply security best practices, where possible.
- MitigationGuardLogix 5580
Customers using the affected software, who are not able to upgrade to one of the corrected versions, are encouraged to apply security best practices, where possible.
- Fixed1756-EN4TR
1756-EN4TR: Update to version 4.001 and later
- FixedCompact GuardLogix 5380
Compact GuardLogix 5380: Update to v33.015 and later for versions 33. Update to v34.011 and later
- FixedCompactLogix 5380
CompactLogix 5380: Update to v33.015 and later for versions 33. Update to v34.011 and later
- FixedCompactLogix 5480
CompactLogix 5480: Update to v33.015 and later for versions 33. Update to v34.011 and later
- FixedControlLogix 5580
ControlLogix 5580: Update to v33.015 and later for versions 33. Update to v34.011 and later
- FixedGuardLogix 5580
GuardLogix 5580: Update to v33.015 and later for versions 33. Update to v34.011 and later
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan