PTC Kepware KEPServerEX (Update A)
Successful exploitation of these vulnerabilities could allow an attacker to crash the device or remotely execute arbitrary code.
describes (2)
Related CVEs.
| ID | severity | exploitable | ||
|---|---|---|---|---|
| CVE-2022-2848US | critical9.1 | — | ||
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Kepware KEPServerEX 6.11.718.0. Authentication is not required to exploit this vul… | ||||
| CVE-2022-2825US | critical9.8 | — | ||
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Kepware KEPServerEX 6.11.718.0. Authentication is not required to exploit this vul… | ||||
references
External citations — patches, advisories, analysis.
- ICS Advisory ICSA-22-242-10 JSONself
- Recommended Practicesexternal
- Recommended Practicesexternal
- Recommended Practicesexternal
remediations (16)
- MitigationGE Digital Industrial Gateway Server
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationGE Digital Industrial Gateway Server
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationKepware KEPServerEX
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationKepware KEPServerEX
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationOPC-Aggregator
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationOPC-Aggregator
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationRockwell Automation KEPServer Enterprise
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationRockwell Automation KEPServer Enterprise
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationSoftware Toolbox TOP Server
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationSoftware Toolbox TOP Server
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationThingWorkx Industrial Connectivity
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationThingWorkx Industrial Connectivity
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationThingWorkx Kepware Edge
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationThingWorkx Kepware Edge
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationThingWorkx Kepware Server
OPC-Aggregator: should upgrade to v6.12 or later
- MitigationThingWorkx Kepware Server
OPC-Aggregator: should upgrade to v6.12 or later
Advisories like this name the exposed products attackers go after on your perimeter. See what is exposed on your perimeter with a free passive scan.
Free scan